FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   ProfileProfile   You have no new messagesYou have no new messages   Log out [ videora ]Log out [ videora ] 

Videora crashes if alot of files found for download
Goto page Previous  1, 2, 3, 4, 5  Next
 
Post new topic   Reply to topic    videora.com Forum Index -> Videora Support
View previous topic :: View next topic  
Author Message
molitar



Joined: 15 Aug 2005
Posts: 154

PostPosted: 09 Jan 2006 09:35 am    Post subject: Reply with quote Edit/Delete this post Delete this post View IP address of poster

Ok the crash happened so I'm attaching an image of it for you.

http://molitar.dnip.net/files/error.png


Last edited by molitar on 15 Jan 2006 01:39 am; edited 1 time in total
Back to top
View user's profile Send private message Send e-mail
videora
Forum Administrator


Joined: 25 Dec 2004
Posts: 619

PostPosted: 10 Jan 2006 02:19 pm    Post subject: Reply with quote Edit/Delete this post Delete this post View IP address of poster

Well the second exception you posted is not very helpful as it seems to be some sort of Window problem. We'll look into that further.

As for that cryptic box, we have no idea why that is occuring. The only thing we can recommend at this point would be to run Videora through the .NET debugger to try to catch the actual error information.

To do this, you must first download the .NET SDK from here:
http://www.microsoft.com/downloads/details.aspx?FamilyId=9B3A2CA6-3647-4070-9F41-A333C6B9181D&displaylang=en

Once you've got that downloaded, follow the directions on this page:
http://www.icsharpcode.net/heyhey/wiki/ow.asp?HowToDebug

You can use the first method and DOS if you want, I'd probably suggest
the second one " How to Debug with GUI", its probably simplier.
_________________
Thanks,
Videora Software Support
Videora FAQ
Back to top
View user's profile Send private message Send e-mail
showdown



Joined: 09 Jan 2006
Posts: 3

PostPosted: 10 Jan 2006 03:49 pm    Post subject: Videora link will not open Reply with quote Edit/Delete this post Delete this post View IP address of poster

they reset the link but it will not open
Back to top
View user's profile Send private message Send e-mail
molitar



Joined: 15 Aug 2005
Posts: 154

PostPosted: 10 Jan 2006 04:25 pm    Post subject: Reply with quote Edit/Delete this post Delete this post View IP address of poster

Ok I downloaded it and installed it.. I set the settings for Videora to be...

Program to debug: C:\Program Files\Videora\Videora.exe
arguments: "${TargetPath}"
working directory: C:\Program Files\Videora

Than I hit the start button it shows the debug window for less than a second than it's like the application closes itself as soon as it goes to start. So it seems the release version won't run with a debugger running.

Just wanted to add the debugger is working for other applications so it seems this version has protection to watch for debuggers running in the background.
Back to top
View user's profile Send private message Send e-mail
molitar



Joined: 15 Aug 2005
Posts: 154

PostPosted: 12 Jan 2006 09:38 am    Post subject: Reply with quote Edit/Delete this post Delete this post View IP address of poster

Still waiting to hear something new.. btw I tweaked my windows default debugging some.. so now I'm getting a bit more of an error message..

http://molitar.dnip.net/images/application_error.png


Last edited by molitar on 15 Jan 2006 01:39 am; edited 1 time in total
Back to top
View user's profile Send private message Send e-mail
videora
Forum Administrator


Joined: 25 Dec 2004
Posts: 619

PostPosted: 13 Jan 2006 02:45 am    Post subject: Reply with quote Edit/Delete this post Delete this post View IP address of poster

There won't be anything new as we have seem to hit a wall.

It seems that we have fixed your first problem with our latest version as you are no longer mentioning that issue any more.

Upon further examination we are unable to fix the second Exception you mentioned:
Quote:

System.ComponentModel.Win32Exception: Error creating window handle.

There seems to be some sort of problem internal to the Windows GUI libraries that Videora uses and there is no way for us to fix this. What we can do, if you are able to "continue" from this exception and continue using the program fine, is at least stop Exception box from popping up.

Finally your third issue gives us very little to work with. Unless you are able to give us some more concrete information with the CLR Debugger there is nothing we can do other than provide you with the information below. We are able to run the released version of Videora fine in the CLR Debugger on multiple machines so we are preplexed why it does not work for you.

The "Videora.exe - Application Error" box seems to indicate that there is a memory problem on your computer. You should monitor the memory usage of your computer when Videora is active. You might also want to run a memory test. Microsoft has acknowledged that .NET applications under heavy loads may be a cause of such problems. You can read more about this in their Knowledge Base article.
http://support.microsoft.com/default.aspx?scid=kb;en-us;830724
_________________
Thanks,
Videora Software Support
Videora FAQ
Back to top
View user's profile Send private message Send e-mail
molitar



Joined: 15 Aug 2005
Posts: 154

PostPosted: 15 Jan 2006 01:16 am    Post subject: Reply with quote Edit/Delete this post Delete this post View IP address of poster

Discovered an issue with NetLimiter for one.. I was getting alot more crashes after installing NetLimiter.

Ahh finally found out issue with the debugger. It seems it's because Net Framework 2.x was installed. BTW you might want to read about this at...

http://blogs.msdn.com/jmstall/archive/2005/12/05/VS2003_crashes_with_2005.aspx

as soon as I removed framework 2.0 I am now able to attach to process. Now since it usually only happens if I have not run videora in at least a day so that their is at least 6 new downloads guess I'll have to wait to I can use the debugger to start the application next time.
Back to top
View user's profile Send private message Send e-mail
molitar



Joined: 15 Aug 2005
Posts: 154

PostPosted: 15 Jan 2006 08:45 am    Post subject: Reply with quote Edit/Delete this post Delete this post View IP address of poster

Ok I hope this will help you resolve the issue.. this is the debugger information...

'DefaultDomain': Loaded 'c:\windows\microsoft.net\framework\v1.1.4322\mscorlib.dll', No symbols loaded.
'Videora': Loaded 'C:\Program Files\Videora\Videora.exe', No symbols loaded.
'Videora.exe': Loaded 'c:\windows\assembly\gac\system.windows.forms\1.0.5000.0__b77a5c561934e089\system.windows.forms.dll', No symbols loaded.
'Videora.exe': Loaded 'c:\windows\assembly\gac\system\1.0.5000.0__b77a5c561934e089\system.dll', No symbols loaded.
'Videora.exe': Loaded 'c:\program files\videora\interop.shdocvw.dll', No symbols loaded.
'Videora.exe': Loaded 'c:\program files\videora\axinterop.shdocvw.dll', No symbols loaded.
'Videora.exe': Loaded 'c:\windows\assembly\gac\system.drawing\1.0.5000.0__b03f5f7f11d50a3a\system.drawing.dll', No symbols loaded.
'Videora.exe': Loaded 'c:\program files\videora\videoraui.controls.listviewex.dll', No symbols loaded.
'Videora.exe': Loaded 'c:\windows\assembly\gac\accessibility\1.0.5000.0__b03f5f7f11d50a3a\accessibility.dll', No symbols loaded.
'Videora.exe': Loaded 'c:\windows\assembly\gac\system.xml\1.0.5000.0__b77a5c561934e089\system.xml.dll', No symbols loaded.
'Videora.exe': Loaded 'gfpa6fgw', No symbols loaded.
'Videora.exe': Loaded 'suw6advm', No symbols loaded.
'Videora.exe': Loaded 'uemjpqtn', No symbols loaded.
'Videora.exe': Loaded 'dg25mzon', No symbols loaded.
'Videora.exe': Loaded '8zsqz4gf', No symbols loaded.
'Videora.exe': Loaded 'epa02ru_', No symbols loaded.
'Videora.exe': Loaded 'otbs2zln', No symbols loaded.
'Videora.exe': Loaded '7yqgcckl', No symbols loaded.
'Videora.exe': Loaded 'lowbzxv4', No symbols loaded.
'Videora.exe': Loaded 'eaw8yzql', No symbols loaded.
The thread 'Splash Screen' (0xb00) has exited with code 0 (0x0).
The thread 'TorrentSpy' (0x588) has exited with code 0 (0x0).
The thread 'Tokyo Toshokan' (0x3fc) has exited with code 0 (0x0).
The thread 'UnrealTorrents' (0x590) has exited with code 0 (0x0).
The thread '<No Name>' (0x9b4) has exited with code 0 (0x0).
The thread '<No Name>' (0x42c) has exited with code 0 (0x0).
The thread 'BitTorrent @ AnimeSuki.com' (0x928) has exited with code 0 (0x0).
The thread 'The Pirate Bay - Other' (0x4ac) has exited with code 0 (0x0).
The thread 'DA.org Torrents' (0x30c) has exited with code 0 (0x0).
The thread '<No Name>' (0x9d4) has exited with code 0 (0x0).
The thread '<No Name>' (0x9d8) has exited with code 0 (0x0).
The thread '<No Name>' (0xf74) has exited with code 0 (0x0).
The thread '<No Name>' (0x9dc) has exited with code 0 (0x0).
The thread '<No Name>' (0x9e0) has exited with code 0 (0x0).
The thread '<No Name>' (0x9fc) has exited with code 0 (0x0).
The thread '<No Name>' (0x9f8) has exited with code 0 (0x0).
The thread '<No Name>' (0x9f0) has exited with code 0 (0x0).
The thread '<No Name>' (0x9e8) has exited with code 0 (0x0).
The thread '<No Name>' (0x9f4) has exited with code 0 (0x0).
The thread '<No Name>' (0xff4) has exited with code 0 (0x0).
The thread '<No Name>' (0x5bc) has exited with code 0 (0x0).
The thread 'Baka Updates' (0x930) has exited with code 0 (0x0).
An unhandled exception of type 'System.ComponentModel.Win32Exception' occurred in system.windows.forms.dll

Additional information: Error creating window handle.


Unhandled Exception: System.ComponentModel.Win32Exception: Error creating window handle.
at System.Windows.Forms.NativeWindow.CreateHandle(CreateParams cp)
at System.Windows.Forms.Control.CreateHandle()
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl()
at System.Windows.Forms.Control.OnVisibleChanged(EventArgs e)
at System.Windows.Forms.ScrollableControl.OnVisibleChanged(EventArgs e)
at System.Windows.Forms.Control.OnParentVisibleChanged(EventArgs e)
at System.Windows.Forms.Control.OnVisibleChanged(EventArgs e)
at System.Windows.Forms.Control.OnParentVisibleChanged(EventArgs e)
at System.Windows.Forms.Control.OnVisibleChanged(EventArgs e)
at System.Windows.Forms.ScrollableControl.OnVisibleChanged(EventArgs e)
at System.Windows.Forms.Control.OnParentVisibleChanged(EventArgs e)
at System.Windows.Forms.Control.OnVisibleChanged(EventArgs e)
at System.Windows.Forms.ScrollableControl.OnVisibleChanged(EventArgs e)
at System.Windows.Forms.Control.OnParentVisibleChanged(EventArgs e)
at System.Windows.Forms.Control.OnVisibleChanged(EventArgs e)
at System.Windows.Forms.ScrollableControl.OnVisibleChanged(EventArgs e)
at System.Windows.Forms.Control.SetVisibleCore(Boolean value)
at System.Windows.Forms.Control.set_Visible(Boolean value)
at System.Windows.Forms.TabPage.set_Visible(Boolean value)
at System.Windows.Forms.TabControl.UpdateTabSelection(Boolean uiselected)
at System.Windows.Forms.TabControl.OnSelectedIndexChanged(EventArgs e)
at System.Windows.Forms.TabControl.set_SelectedIndex(Int32 value)
at System.Windows.Forms.TabControl.set_SelectedTabInternal(TabPage value)
at System.Windows.Forms.TabControl.set_SelectedTab(TabPage value)
at Videora.4c18069c48bd2157.cd2d789fb601fbbd(Object e0292b9ed559da7d, EventArgs fbf34718e704c6bc)
at VideoraUI.Controls.ListViewEx.TreeListView.OnSelectedItemChanged()
at VideoraUI.Controls.ListViewEx.TreeListView.OnMouseDown(MouseEventArgs e)
at System.Windows.Forms.Control.WmMouseDown(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at VideoraUI.Controls.ListViewEx.ContainerListView.WndProc(Message& m)
at System.Windows.Forms.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.DebuggableCallback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
at System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG& msg)
at System.Windows.Forms.ComponentManager.System.Windows.Forms.UnsafeNativeMethods+IMsoComponentManager.FPushMessageLoop(Int32 dwComponentID, Int32 reason, Int32 pvLoopData)
at System.Windows.Forms.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
at System.Windows.Forms.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.Run(Form mainFThe thread '<No Name>' (0x760) has exited with code 0 (0x0).
The thread '<No Name>' (0x560) has exited with code 0 (0x0).
orm)
at Videora.4c18069c48bd2157.c447809891322395(String[] b6ae8b697e41dbde)
Back to top
View user's profile Send private message Send e-mail
videora
Forum Administrator


Joined: 25 Dec 2004
Posts: 619

PostPosted: 15 Jan 2006 02:51 pm    Post subject: Reply with quote Edit/Delete this post Delete this post View IP address of poster

Can you please describe the context in which the error occured. In other words, what did you do to cause this error.
Does this error happen automatically on startup?

Also, when the exception pops up, is there a "Continue" button?
What happens if you click that?
Does Videora still work fine?
_________________
Thanks,
Videora Software Support
Videora FAQ
Back to top
View user's profile Send private message Send e-mail
molitar



Joined: 15 Aug 2005
Posts: 154

PostPosted: 15 Jan 2006 06:25 pm    Post subject: Reply with quote Edit/Delete this post Delete this post View IP address of poster

It happens just after starting the application.. First thing I note is that the entire right side of the screen will sometimes turn completely gray. When I see this I know for 100% that it will fail. If I hit continue it will sometimes it will shut down.. othertimes it just can't be used and I have to than alt+end+task it. It happens mostly if when I start the app it seems to have alot of new downloads perhaps it's trying to start the downloads too fast before it's fully loaded up because even before it's finished loading I will have a window that indicates duplicate download do I wish to skip from ABC. Second thing is I've started to get alot of downloads redownloading lately after this latest release, perhaps it doesn't have time to read the entire downloaded history before it starts trying to download. If I am disconnected from the network by disabling my nic I don't seem to crash from the few tests I have done with it. Also for some reason if I minimize the application first it is less likely to crash still crashes occasionaly but not as often. And since removing NetLimiter it's helped with some of the crashing also.

System:
Nforce3 Ultra Mainboard
Onboard Realtek RTL8169/8110 Family Gigabit Ethernet NIC
AMD 64 3000+
WinXP SP2 32bit (all latest updates)
Geforce 6600GT 128Megs
X-Mystique Dolby Live Soundcard
ATA 133 drive
2 SATA Drives
1 DVD Writer
1 CD Writer

Using latest ABC 3.2 Unicode release by Kratoak
Back to top
View user's profile Send private message Send e-mail
videora
Forum Administrator


Joined: 25 Dec 2004
Posts: 619

PostPosted: 17 Jan 2006 04:33 am    Post subject: Reply with quote Edit/Delete this post Delete this post View IP address of poster

Even with the additional information provided, there is still no quick fix.

We will continue to try things but fixing a problem that we cannot reproduce ourselves, nor can we identify the cause, is no easy task. We will try our best to determine what is wrong and let you know if we determine anything.

At this time we can only recommend that you try to minimize the amount of times you need to start Videora up.

As for re-downloading, Videora only saves the Download History upon exit to reduce disk accesses. This means if Videora crashes without closing properly, all downloads made during the time the application was working will be lost and Videora will re-download them the next time it starts up.
_________________
Thanks,
Videora Software Support
Videora FAQ
Back to top
View user's profile Send private message Send e-mail
molitar



Joined: 15 Aug 2005
Posts: 154

PostPosted: 17 Jan 2006 06:20 am    Post subject: Reply with quote Edit/Delete this post Delete this post View IP address of poster

Hmm.. why not have it write what it's downloaded when it is minimized just like the other settings do? It's a pain to have files redownloaded if computer reboots, application crashes, ect. Now that explains why when I had a power failure I had 20+ files from the last few days redownloading and I had to remove them all from my torrent client.
Back to top
View user's profile Send private message Send e-mail
molitar



Joined: 15 Aug 2005
Posts: 154

PostPosted: 25 Jan 2006 04:30 am    Post subject: Reply with quote Edit/Delete this post Delete this post View IP address of poster

Ok I found another cause for crashes.. My computer had a crash just recently. Afterward everytime I tried to restart it it would crash again with similar error. So I did two things cleaned out all the torrents under videora/torrent folder.. their was alot with duplicates named <torrent name.001, ect.. Second thing I did to fix this was replace this history.xml file.. it seems this file gets corrupted on a computer crash at times and causes issues with Videora. Their needs to be some type of checker in videora if a file is missing or corrupt for it to rebuild it or something.
Back to top
View user's profile Send private message Send e-mail
videora
Forum Administrator


Joined: 25 Dec 2004
Posts: 619

PostPosted: 25 Jan 2006 05:29 pm    Post subject: Reply with quote Edit/Delete this post Delete this post View IP address of poster

We'll look into it.
_________________
Thanks,
Videora Software Support
Videora FAQ
Back to top
View user's profile Send private message Send e-mail
flic



Joined: 25 Jan 2005
Posts: 9

PostPosted: 05 Feb 2006 01:54 pm    Post subject: Reply with quote Edit/Delete this post Delete this post View IP address of poster

Looks like I have the same problem, or a similar one. When I posted this earlier you told me that it had something to do with Videora being unable to download one of my RSS feeds and failing dramatically.

Seriously guys, I've been with you since version one and I love the app, but v2 seems to have some serious flaws! I've tried to run it on two different XP SP2 clients (one of them a clean install) and a Win2003 install. It just doesn't seem to be able to stay alive on any of them for any length of time! It was a long time since it actually managed to download something for me.

This is my latest error, directly at startup. Sometimes I get the same grey window as explained above and sometimes not. Either directly at startup or when I click on the RSS Feeds button I get the following:

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ComponentModel.Win32Exception: Error creating window handle.
at System.Windows.Forms.NativeWindow.CreateHandle(CreateParams cp)
at System.Windows.Forms.Control.CreateHandle()
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl()
at System.Windows.Forms.Control.OnVisibleChanged(EventArgs e)
at System.Windows.Forms.ScrollableControl.OnVisibleChanged(EventArgs e)
at System.Windows.Forms.Control.OnParentVisibleChanged(EventArgs e)
at System.Windows.Forms.Control.OnVisibleChanged(EventArgs e)
at System.Windows.Forms.Control.OnParentVisibleChanged(EventArgs e)
at System.Windows.Forms.Control.OnVisibleChanged(EventArgs e)
at System.Windows.Forms.ScrollableControl.OnVisibleChanged(EventArgs e)
at System.Windows.Forms.Control.OnParentVisibleChanged(EventArgs e)
at System.Windows.Forms.Control.OnVisibleChanged(EventArgs e)
at System.Windows.Forms.ScrollableControl.OnVisibleChanged(EventArgs e)
at System.Windows.Forms.Control.OnParentVisibleChanged(EventArgs e)
at System.Windows.Forms.Control.OnVisibleChanged(EventArgs e)
at System.Windows.Forms.ScrollableControl.OnVisibleChanged(EventArgs e)
at System.Windows.Forms.Control.SetVisibleCore(Boolean value)
at System.Windows.Forms.TabPage.set_Visible(Boolean value)
at System.Windows.Forms.TabControl.UpdateTabSelection(Boolean updateFocus)
at System.Windows.Forms.TabControl.OnSelectedIndexChanged(EventArgs e)
at System.Windows.Forms.TabControl.WmSelChange()
at System.Windows.Forms.TabControl.set_SelectedIndex(Int32 value)
at System.Windows.Forms.TabControl.set_SelectedTab(TabPage value)
at Videora.4c18069c48bd2157.cd2d789fb601fbbd(Object e0292b9ed559da7d, EventArgs fbf34718e704c6bc)
at VideoraUI.Controls.ListViewEx.TreeListView.OnSelectedItemChanged()
at VideoraUI.Controls.ListViewEx.TreeListView.OnMouseDown(MouseEventArgs e)
at System.Windows.Forms.Control.WmMouseDown(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at VideoraUI.Controls.ListViewEx.ContainerListView.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    videora.com Forum Index -> Videora Support All times are GMT
Goto page Previous  1, 2, 3, 4, 5  Next
Page 2 of 5
Watch this topic for replies
 
Delete this topic Move this topic Lock this topic Split this topic 
Jump to:  
You can post new topics in this forum
You can reply to topics in this forum
You can edit your posts in this forum
You can delete your posts in this forum
You can vote in polls in this forum
You can moderate this forum

Go to Administration Panel


Powered by phpBB © 2001, 2002 phpBB Group